Stoat Status Machine

Email provider under heavy load

  • Identified
    Our domain has been successfully removed from the Spamhaus DBL blocklist. Email deliverability has been restored, and messages should no longer be rejected.
    
    However, due to a backlog of queued messages, our email service provider is still processing a higher-than-normal volume of mail. As a result, some emails may experience delays of approximately 20 minutes.
    
    We will continue to monitor the situation and provide further updates as needed.
  • Identified
    We are aware of mail deliverability issues, we are currently listed on Spamhaus DBL and are trying to actively resolve the issue.
    
    Some emails may also be delayed, this is likely due to the sheer volume of requests going to our service provider. We have mitigated this by increasing verification email expiry.